This project is read-only.


Apr 10, 2012 at 3:07 AM

Hello Oleg

Can you tell us when you will have a version that works with Visual Studio 11 please? 

Apr 15, 2012 at 1:20 PM

Sure, I'll let you know as soon as I have it :).


May 14, 2012 at 5:24 PM

I spent a lot of time trying to get T4Toolbox to work with VS11, including re-compiling with the v11 references, rebuilding the setup (to change the registry entries) and got pretty close, but still couldn't get past one error. Of course, I am at work and cannot remember the error now. I am sure Oleg is much smarter than I, and knows more about it too, so he should be able to figure it out. I believe the error was related to "resolving" a processor.



Jun 2, 2012 at 8:36 AM
Edited Jun 2, 2012 at 8:49 AM

Hey Oleg

I've got T4Toolbox running under VS2012 RC. I was wondering if I might possibly be of assistance?


  • My attempts to stick with .Net 4.0 failed due to run-time reference resolution issues. I found no alternative than to go with .Net 4.5 which required a few extra lines of conditionally compiled code.
  • Getting StyleCop support for VS2012 necessitated an upgrade to StyleCop 4.7 (from 4.4)
  • I resolved issue 15577

What I haven't yet done but still intend/hope to do:

  • Go back to VS2010 and ensure I haven't broken compatibility.
  • Discuss with you if you would allow CSharpTemplate.FieldName(string) to become non-static and virtual. This would help us support our coding guidelines with much less effort.

What I haven't yet done but might be willing to:

  • I have no experience with WiX, but it looks easy enough so I would be willing to take a shot at updating the installer. However, I would need some guidance. As far as i know, getting support for VS2012 also necessitates an upgrade. Would this interfere with VS2010 compatibility? Is that important? Is it acceptable to use the latest version which is currently just a release candidate? etc. etc.

What I can not do:

  • Go back to VS2008 and ensure I haven't broken compatibility.  Someone else would need to test this for me.

Let me know if any of this interests you. I'm away until Tuesday (June 5th), so I won't be able to get back to you until then.

Take care


Jun 2, 2012 at 11:26 AM

Hi guys

I've also got T4Toolbox running under fresh install of Win8 Release Preview + VS2012 RC.

I've downloaded VS SDKs, WIX 3.6, removed StyleCop, changed references to new dlls -- and build succeeded.

To get it running correctly, need to change version number 10 -> 11 in *.wxs files, and change registry keys to 'HKCU\Software\Microsoft\VisualStudio\11.0_Config'


Jun 7, 2012 at 8:38 PM
Edited Jun 7, 2012 at 8:39 PM

Hey a5Sent, stBear, would one of you be kind enough to send me your wix built setup? rickrat at the gmail.



Jun 10, 2012 at 1:22 PM


I have not yet spent any time trying to update the WiX installer for VS11. I might do it at some point, but not before hearing back from Oleg (see my first post).

Jun 17, 2012 at 9:03 AM
Edited Jun 17, 2012 at 9:04 AM

I would really like to get a version that works with VS11 as well, since it is kind of a showstopper for us in switching to the new Visual Studio and .NET framework versions at the moment.  Is there any work from Oleg on this, or any plans on when it might be released?

Jul 3, 2012 at 6:18 PM

Have you tried this installer?

Unfortunately, does not work for me (see comments).

Jul 6, 2012 at 8:22 AM

Neeeed !!!

Jul 6, 2012 at 5:24 PM

Guis, it didn't work for me the first time either, I had to run it again, uninstall, and then run it again to install for it to stick.

Jul 11, 2012 at 3:56 PM

Visual Studio 2012 RC SDK:

Jul 22, 2012 at 1:26 AM

I can't get to the installer listed on the page referenced by guis.  Is there some other location I can get to it?

Jul 22, 2012 at 9:35 AM

I re-uploaded the installer, hope the guys from don't mind.

Take it here:

Aug 4, 2012 at 5:20 PM
Edited Aug 4, 2012 at 5:24 PM

The installer does not work for me. Is there another version available for VS 2012?

Aug 4, 2012 at 10:44 PM

It does work, but if you run vs2010, it hoses it, you have to re-run and repair it.


Aug 4, 2012 at 10:45 PM

Please vote for VS2012 support.


Aug 22, 2012 at 2:45 PM

We also need VS2012 support, I voted at the link above.

I tried the installer here:

But I receive an error when trying to add a new LinqToSql code generator claiming that verson *.1 of T4Toolbox.*.dll could not be loaded. Any timeline on when 2012 support might be official?

Aug 23, 2012 at 2:20 PM

We definitely need help on this one, too.  We created a slew of generated files using this, and now we're having trouble in VS2012.  Nothing knows how to find the reference.  When I add the registry entries from the requested work item (, I still get errors on attempted generation.

Has anyone successfully ported this to VS2012 where they do include the file?


Oct 4, 2012 at 11:40 AM

Hey Oleg,

Any news on that?


Thank you!


Oct 4, 2012 at 11:48 AM

As we used T4Toolbox mainly for generating multiple files from one template, we have switched to EF.Utility.CS.ttinclude's EntityFrameworkTemplateFileManager. It required some changes but at least, it works now.

Oct 9, 2012 at 7:54 PM

I've done work to convert the T4 Toolbox to VS 2012. The code is here:

Note the resulting installer works except for the need to manually copy registry keys to HKCU, so it's not really in a generally supportable state.

For sake of completeness, the issue is as follows: all goes well and seems to work except for what appears to be a problem with VS 2012 not copying the configuration correctly from the registry. According to the MSDN docs on deploying a custom T4 directive, this registry technique, which works in VS 2010 and is what the T4 Toolbox installer uses, should continue to work in VS 2012. However, on two different machines it fails, and the way it fails is that the information added to HKLM\SOFTWARE\[Wow6432Node\]Microsoft\VisualStudio\11.0\TextTemplating\DirectiveProcessors and HKLM\SOFTWARE\[Wow6432Node\]Microsoft\VisualStudio\11.0\TextTemplating\IncludeFolders\.tt never gets copied to the respective key in HKCU\...\11.0_Config\...\ like happens in VS 2010. Manually copying this information to HCKU resolves this. I'm thinking that there may be a missing step to get VS to copy this configuration over, although I have run "devenv /setup" and "devenv /InstallVSTemplates" to no avail.

Oct 16, 2012 at 11:04 PM

Does this work with VS2010 and VS2012 both ways?

Oct 17, 2012 at 12:41 AM
rickrat wrote:

Does this work with VS2010 and VS2012 both ways?

What does this mean?

Oct 17, 2012 at 2:35 AM

Meaning the installer works for VS2008, VS2010 and VS2012? Or was it just modified to support 12?

Oct 17, 2012 at 3:33 AM

Ah, got it. Well the installer already supported VS2008 and VS2010, and I added VS2012 (with the problems enumerated above). I tested it on VS2010 with no problems, but I don't have VS2008.

Oct 19, 2012 at 6:22 AM


One of the challenges I have seen, is after running VS2010, then closing it, then running VS2012, T4 generation no longer happens in 2012. Does your installer fix this specific issue?



Oct 19, 2012 at 7:06 AM
Does your installer fix this specific issue?

I don't know. I wouldn't imagine it would, but feel free to test it.

Oct 29, 2012 at 5:35 PM

It there any kind of estimation for the date of a release with support to VS2012? 

Thank you

Nov 22, 2012 at 7:08 PM
Edited Nov 27, 2012 at 5:58 PM

Well it seems I managed to make it work without problems, following these steps:

1. I obtained the installer using the sources provided by codekaizen,

2. I installed it on my computer.

3 I have added entries codekaizen indicated to the registry of my computer.

Just doing that, it works properly on my computer. However when I execute the installer and add the entries on other computers it doesn't work.

The "trick" that solved this problem was to install VS2012 SDK on these others computers where it failed .

Now I have T4Toolbox running properly on VS2010 and VS2012 

Hope it helps!

Dec 8, 2012 at 9:58 AM
Edited Dec 8, 2012 at 10:05 AM
codekaizen wrote:

For sake of completeness, the issue is as follows: all goes well and seems to work except for what appears to be a problem with VS 2012 not copying the configuration correctly from the registry. [...] I'm thinking that there may be a missing step to get VS to copy this configuration over, although I have run "devenv /setup" and "devenv /InstallVSTemplates" to no avail.

Have you tried devenv /updateconfiguration ? This has fixed the issue for me on an addin I'm developing which had the same problem. It seems that VS2012 keeps a flag to avoid copying registry entries at each startup, and that /updateconfiguration clears it. Note that I was using a pkgdef file to set the registry keys (which should be the preferred technique).

Dec 29, 2012 at 6:12 AM

T4 Toolbox (beta) for Visual Studio 2012 is now available:

Jan 5, 2013 at 4:28 AM

@MrJul  ->> Have you tried devenv /updateconfiguration ?

Confirm that it solves the problem, ie HKLM settings are copied to HKCU/.../11.0_Config/ on next VS2012 start. Thanks for tip.