Preprocessed Templates are not supported in VS2012

Support is still needed for preprocessed templates in VS2012. Currently I need to use VS2010 and rollback the projects from .net 4.5 to 4.0 so that I can generate files using my generator. I need...

Id #24844 | Release: None | Updated: Nov 6, 2013 at 5:59 AM by jimmymain | Created: Nov 2, 2013 at 8:46 PM by bit7

VS 2013 Support

Hi, do you plan to support the VS 2013 any time soon ? Thanks

Id #24823 | Release: None | Updated: Sep 15 at 4:25 PM by JordonKraft | Created: Oct 22, 2013 at 1:44 PM by khorvat

Remoting exception for long running templates

I have a template that runs overs large database (meta data copied to local XML to make it faster) however it takes more than 15 minutes to generate and throws a remoting exception. I also have my...

Id #24640 | Release: None | Updated: Aug 20, 2013 at 1:45 PM by pareshvarde | Created: Aug 20, 2013 at 1:45 PM by pareshvarde

T4 Toolbox settings are not loaded/saved properly

Using the current version of T4 Toolbox, the setting are listed in Tools | Options | T4 Toolbox, and appear to be stored in the Registry under HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11....

Id #24427 | Release: None | Updated: Apr 30 at 12:59 PM by KeesDijk | Created: Jun 21, 2013 at 10:06 AM by flcdrg

DbContext support

Please add templates for DbContext and POCO classes instead of ObjectContext and EntityObject.

Id #22688 | Release: None | Updated: Sep 15 at 4:25 PM by JordonKraft | Created: May 4, 2012 at 12:01 AM by weitzhandler

SQL Server Compact edition (CE) support

Please add support for SQL Server Compact edition in Entity-Framework DAL template.

Id #22687 | Release: None | Updated: Feb 22, 2013 at 12:05 AM by weitzhandler | Created: May 3, 2012 at 11:58 PM by weitzhandler

Using T4 and Postsharp.

We have a number of T4 templates which are used for combining a lot of static javascript and css in one file. All work good until we started using PostSharp for some aspects.   We are using PostSha...

Id #22218 | Release: None | Updated: Feb 22, 2013 at 12:05 AM by AenSidhe | Created: Feb 14, 2012 at 10:36 AM by AenSidhe

Installer succeeds, but I don't see any changes

When installing it says it succeeds but syntax highlighting (which I use at home) is not present. I can't seem to validate if anything has changed at all. Looking at the source of the Wix it seems ...

Id #22062 | Release: None | Updated: Feb 22, 2013 at 12:05 AM by ImaginaryDev | Created: Jan 13, 2012 at 2:25 PM by ImaginaryDev

visual studio 2008

does the latest build work in visual studio 2008? I have been trying to open an XmlDocument for use on a template but I get nothing but errors. The assembly statement shows a green underline and...

Id #22050 | Release: None | Updated: Feb 22, 2013 at 12:05 AM by markmemorial | Created: Jan 11, 2012 at 11:03 PM by markmemorial

Circular reference when entity is processed by the JsonSerializer.

I've opened a discussion regarding this issue here: http://t4toolbox.codeplex.com/discussions/280364   I can't seem to get the project to open without error or I would offer the fix. Could someon...

Id #21818 | Release: None | Updated: Feb 22, 2013 at 12:05 AM by tgoyer | Created: Nov 23, 2011 at 1:58 AM by tgoyer